Minimum Requirements

You can install the Sherish app on iPhone and iPod devices that are running iOS 6.0 or higher.

One vote